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INTRODUCTION: 
 
In this training course we will be using KompoZer as the web editor. KompoZer is (WYSIWYG) What-
You-See-Is-What-You-Get web authoring system. Kompozer can be used to create, edit and publish your 
files to the web.  
 
In this training course you will receive information on how to access your web space along with learning 
basic concepts of KompoZer and its functionality. 
 

GETTING HELP: 
To get further help or more information on KompoZer, you can obtain help from different sources:  
 
KompoZer Help center 

 
Help Menu in the KompoZer application can be 
accessed from the Help Menu and then select Help 
Contents. 

 
IAS Information 
Technology Group  

The Information Technology Group can be reached     
Monday through Friday between the hours of 8:00 
a.m. and 5:00 p.m. by telephone (extension 8044) or 
by e-mail (helpdesk@ias.edu) 

 
 

Reference Websites: 

http://www.charlescooke.me.uk/web/kz-ug-home.htm 
http://www.chromakinetics.com/Kompozer/KompoZer%
20User%20Guide.pdf 
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WORKING WITH WEBSPACE: 
All clients supported by the Information Technology group have a web space available for academic use.  

Please note: Your web space is to be used for scholarly and administrative purposes only. It may not be 
used for commercial purposes or for financial gain. Please read the Institute's Computer use Policy for 
details. 

Your web space contains a file called index.html, which is placed there to serve as a default page. You 
may edit, or replace, this page. If you are interested in using the logo, it can be found at the following URL. 

http://people.ias.edu/fuld_icon.jpg 

All web spaces are reached by visiting http://people.ias.edu/~username with username being replaced 
with your individual username. For example, if your username is jdoe, then your web space would be 
reached at http://people.ias.edu/~jdoe. 

Note: If you are staff or faculty, your web space will not be located in your I-drive. You will have your own 
directory located at \\itgfs\users\. You will need to map your computer to this location in order access your 
web space. If you need assistance with this, please contact the Help Desk. 
 

Windows 

The web space for members is located directly within the I:\ drive, which is mapped to 
\\itgfs\users\username. In this case, the personal web space can be accessed by following these 
instructions. 

These instructions assume that you are using an Institute provided office computer. 

1. Double-click on My Computer 
2. Double-click on the I:\ drive 
3. Double-click the public_html folder 
4. Inside this folder is a sample webpage that you can edit, or replace, called index.html. This index 

page contains the current ITG template. You can edit this page using any webpage editing 
program currently installed on your computer. You could also open your web page editor, and 
open the index.html page from within the program. The path to the page is 
I:\public_html\index.html 

These instructions assume that you are using your personal computer. 

If you would like to access your personal web space from your personal computer you will need to follow 
these steps 

1. Connect to Institute for Advanced Study VPN, further information can obtained from the following 
link: http://www.itg.ias.edu/net/vpn 

2. You will need to map to your computer to the appropriate network drive. For instructions on how 
to map a network drive please visit: 
http://www.itg.ias.edu/networkresources/accessingfiles/accessingfiles 

• If you are Staff then you will need to map your computer to the following network drive: 
\\itgfs\users\ 
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• If you are a Member you will need to map your computer to your home drive which is 
your I drive \\itgfs\users\username 

Unix 

If you have a UNIX account, provided by ITG, you can access your personal web space in the following 
way. 

1. Start a SSH session in remote.itg.ias.edu 
2. Type cd public_html 
3. Type ls. This will show you the directory listing for your web space. By default, there is a sample 

webpage that you can edit, or replace, called index.html. 
4. Use a text editor such as vi or grep to edit the index.html file. 

GETTING STARTED WITH KOMPOZER: 
 
The KompoZer interface consists of three main areas:  
 

• Toolbars – Located at the top of the window, contains multiple toolbars for managing files and 
editing content. Toolbars can be added or removed based on personal preference.  

• Site Manager – Located at the left, this section contains shortcuts to website directories that can 
be managed through KompoZer. 

• Main content window – Located in the middle of the interface, this section contains all open files, 
tabs for changing the view of the file, and tabs for switching between open files. 

 

 

Toolbars 

View Tabs 
Site Manager 

File Tab 

Content Area 
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ADDING FILES USING SITE MANAGER: 
 
The Site Manager contains shortcuts to website directories that can be managed through KompoZer. Any 
website that is edited regularly can be added, for ease of access. 
 
To add a new site to the Site Manager, do the following: 
 

1. Make sure the Site Manager is visible in the main window. If it is not, go to the View menu, then 
Show/Hide, then Site Manager. You can also use the F9 key. 

2. Click on the Double Computer icon. 
 

 
 

 
 

3. A new window will appear that will allow you to edit existing site information, and add new ones. 
4. Next to Site Name, put in the name you want to use to reference the site. This is the name you 

will see in the Site Manager directory listing. Note: If the boxes for filling in information for the 
new site are not empty click the New Site button. 

5. Under Web Site Information, type in the address of your website. For this example we are going 
to use our http://people.ias.edu/~username/ website address 

6. Under Publishing Server, click the Select Directory button. A new window will appear. 
7. Browse to the directory you wish to use. For most cases this will be your I:\ drive. 
8. Once the correct directory is highlighted, click the OK button. 
9. In the Publish Settings window, under Publishing address, it will say something similar to 

file://I:/. For this example we will have file://I:/username/public_html/ 
10. Click the OK button. 
11. The Publish Settings window will disappear, and the site will be added to the Site Manager 

directory list. 
 
Note: Substitute your username for wherever username has been used. 

 - 4 - 
  
  

http://people.ias.edu/%7Eusername/


  

WORKING WITH SITE MANAGER: 
 
The Site Manager window has a number of toolbar buttons that are used for managing the site. 
 
 
 

 
 
 
 

• Refresh  – Used to refresh a site’s folder list. Sometimes when a change is made, such as 
adding a file, the folder list needs to be refreshed so that the files are properly ordered. 

• New Folder  - Clicking this button will create a new folder in whatever site or folder is 
currently highlighted. A pop-up window will appear asking for the folder name. After the name is 
given, click the OK button to create the folder. 

• Rename file or folder  - To rename a file or folder, highlight the item first, and then click this 
button. A pop-up window will appear asking for the new name.  

• Delete - This button will delete any folder or file that is highlighted. When clicked, a pop-up 
window will appear asking for confirmation. 

• Stop  - This button will stop any currently running process. 
 
 

WORKING WITH THE MAIN CONTENT WINDOW: 
 
The main content window has three basic sections. The top section will display a tab for each open file, 
allowing you to move between them. The middle section contains the file’s contents. Lastly, the bottom 
section contains tabs that are used to switch between views of the same file. 
 
File Tabs 

 
 
To move between each open file, click on the tab at the top. 
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View Tabs 
 

 
 
 
 
The view tabs, at the bottom of the window, change the view of the open file. 
 

• Normal – This view displays the file like any WYSIWYG web editing program. Text is displayed 
like a word processor would, and items such as tables are visible with a dotted line. 

• HTML Tags – This view is similar to Normal view, with the addition of little yellow markers where 
each html tag exists. 

• Source – This view shows the source code of the open file. 
• Preview – This view displays the file the way it will be seen with a web browser. 
 

HOW TO CREATE A NEW PAGE: 
 

1. Click on the File menu bar option. 
2. Click on New. 
3. A new window will appear called “Create a new document or template”. 
4. Check off “A blank document”. 
5. Click on Create. 

 
The second way to create a new page is: 

1. Click on the   icon 
 

HOW TO OPEN AN EXISTING PAGE: 
 
To open an existing page, there are two ways. 
 

1. Click on the File menu bar option. 
2. Click on Open File. 
3. In the Look in field go the location where your page is stored. 
4. Click on Open. 

 
Secondly you can open an existing page by: 
 

1. Click on the  icon 
2. In the Look in field go to the location where your page is stored. 
3. Click on Open. 
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HOW TO SAVE FILES: 
 
There are two ways you can save a file. The first way is to: 
 

1. Click on the File menu bar option. 
2. Click on Save As. 
3. A new dialog window will appear asking for you to enter in a page title 
4. Enter in a title for your page this is not the file name but the title which will be displayed at the top 
5. The “Save Page As” dialog window will appear, browse to the location where you would like to 

save the page and give a file name. You will notice that the file name is set to your title page 
name; you change this to a different file name. 

6. Click on Save. 

Secondly, you can save a page by: 

1. Click on the  icon 
 

HOW TO INSERT TEXT: 
 
To insert text, click on the page where you would like insert text and start typing your information. 
 

• If you would like to change the font of the text follow these steps: 
 
1. Highlight the text. 
2. Click on the Format menu bar.  
3. Click on Font to change the font of the text. 

 
• If you would like to change the size of the text follow these steps: 

 
1. Highlight the text. 
2. Click on the Format menu bar option. 
3. Click on Size. 
 

• If you would like to change the Text Style follow these steps: 
 

1. Highlight the text. 
2. Click on the Format menu bar option. 
3. Click on Text Style. 

 
• If you would like to change the Text Color follow these steps: 

 
1. Highlight the text. 
2. Click on the Format menu bar option. 
3. Click on Text Color. 
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HOW TO CHANGE BACKGROUND COLOR OF THE PAGE: 
 

1. Click on Format in the menu bar. 
2. Click on Page colors and background. 
3. Click on Use Custom Colors. 
4. Click on Background button and select the color. 
5. Click on OK on the Block Background color dialog window. 
6. Click on OK. 
 

HOW TO INSERT AN IMAGE: 
 

1. Click on  icon to insert an image to your webpage or go to Insert Menu and click on 
Image. 

2. For the image location. Click on the Folder icon and browse to image file on your computer. 
3. Select the file. 
4. Select “Don’t use alternate text”. If you would like text to be displayed if your image cannot be 

loaded properly then select “use alternate text” and type in a description. 
5. Click on Open. 
6. Click on the corners of the image to adjust the size. 
 

HOW TO CREATE A LIST: 
 

1. Click on the page where you would like to insert a list. 
2. Click on the Format menu bar option. 
3. Click on the List then choose the list style you would like: 

• Bulleted 
• Numbered 
• Term 
• Definition 
 

HOW TO CHANGE THE STYLE OF BULLETS / NUMBERS: 
 

1. Click on the page where you would like to make the style change. 
2. Click on the Format menu bar option. 
3. Click on the List. 
4. Click on List Properties. 
5. Choose bullet, numbered from the list type. 
6. Then choose the appropriate bullet or number style. 
7. Click on the OK button. 
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HOW TO CREATE LINKS: 
Click on the webpage where you would like to create a link 

1. Click the  icon on the toolbar or Click on Insert and select Link. 
2. In the Link Text field: insert the name of the link.  
3. In the Link Location: Type the local path and filename or remote URL of the page you want to 

link to location field.  
4. URL is relative to page location: If checked, KompoZer converts the URL to be relative to the 

page's location. This is especially useful if you plan to publish your pages to a web server so that 
others can view them. Using relative URLs allows you to keep all your linked files in the same 
place relative to each other, regardless of their location on your hard disk or a web server.  

 

HOW TO INSERT A TABLE: 
 

1. Click on  icon from the toolbar or Click on the Insert menu bar and select Table. You 
also can Click on Table from the menu bar and Click on Insert and select Table. 

2. Under the Precisely Tab Select number of row or column or can do it quickly 
3. Click on OK. 
4. If you would like to change the format of the table double click on the table and the table 

properties will appear. 
 

HOW TO CREATE LINKS WITHIN THE SAME PAGE: 
 
If you need to create links in the same page so you can jump from one section to another section then 
you will need to create anchors. 
 
Click on the page where you would like to create an anchor. 
 

1. Click on the  Icon or Click on Insert and click on Named Anchor. 
2. Type in a name for the anchor. 
3. Click on OK. 
 

Now a link needs to be created so the reader can click on the link and will be directed to the anchor. 
 

1. Select the text you want to link to the anchor. 
2. Click on the Link Button or you can click on the Insert Menu and Select Link. 
3. Link Properties Dialog window will appear. In the Link Location field from the drop down menu 

select the anchor which you just created above. 
4. Click on OK. 
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APPENDIX: 
 
 

ADVANCED SETTINGS 
 
KompoZer’s default settings may not be optimal for some users at IAS, or for the way some webpage’s 
have been coded. Below are a few settings that may need to be changed. 
 
All of these settings can be reached by going to the Tools menu and choosing Preferences… 
 

• Retain original source formatting – Located in the General section, this option tells KompoZer 
to leave the source code the way it is. If not selected, KompoZer can alter line breaks, 
indentations, and other code. 

• Always open a document in a new tab – Located in the General section, this option makes 
sure KompoZer uses tabs for every file. Otherwise, it will open every file in a new KompoZer 
window. 

• Return in a paragraph always creates a new paragraph – Located in the Advanced section. 
When set, hitting the <Enter> key on the keyboard creates a new paragraph, instead of going to 
the next line. It is the difference between creating a new paragraph with the <p> tag or two 
carriage returns with the <br><br> tags. 

• Don’t encode ‘>’ outside of attribute values – Located in the Advanced section, this option 
ensures that KompoZer does not automatically replace the character > with &lt; in the source 
code. This is important, because special code may exist in a document that needs the > symbol 
to function properly. 

 
Note: If you see special code that begins with <% or %> please contact the ITG Help Desk. 

 

 

 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

 - 10 - 
  
  



  

BASIC HTML TAGS: 
 
Page Tags 
 
<html> 
Every HTML document will begin with <html> and end with </html>. These two tags define the beginning 
and end of the document. 
 
<head> 
The <head> and </head> tags define the header section of the HTML document. Some information, such 
as the page title, must be put in the header section. In general, it contains information that is not seen 
within the body of the document. 
 
<title> 
This defines the title given to the document. The title is what is seen at the very top of the web browser 
window. The title is placed inside of the header section. 
 
<body> 
The body section contains most of what you see in the browser window. It begins with <body> and ends 
with </body>. 
 
 
 
Paragraph Tags 
 
<p> 
This tag defines the beginning of a new paragraph. A paragraph generally begins with <p> and ends with 
</p>, but it will function without the </p> tag. 
 
Example 
 
 <p>Hello world!</p><p>Hello again!</p> 
 

will generate… 
 
 Hello world! 
 
 Hello again! 
   

The same can be done with… 
 
<p>Hello world!<p>Hello again! 

 
 
<br> 
This tag defines a line break. It does not have an accompanying end tag. 
 
Example 
 
 <p>Hello world!<br>Hello again!</p> 
 

will generate…  
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 Hello world! 
 Hello again! 
 
<blockquote> 
This tag indents an entire section of text. Any text, or element, between <blockquote> and its end tag will 
be indented. 
 
<ul> 
This tag defines an unordered list, also known as a bulleted list. Each line in the list is defined using the 
<li> tag. 
 
Example 
 
 <ul> 
 <li>Line 1</li> 
 <li>Line 2</li> 
 </ul> 
 
 will generate… 
 

• Line 1 
• Line 2 

 
<ol> 
This tag defines an ordered list, also known as a numbered list. Each line in the list is defined using the 
<li> tag. 
 
Example 
 
 <ol> 
 <li>Line 1</li> 
 <li>Line 2</li> 
 </ol> 
 
 wll generate… 
 

1. Line 1 
2. Line 2 

 
 
 
Text Formatting 
 
<font> 
The <font>tag defines specific font related information for the text it surrounds. The font attributes are 
placed within the tag’s brackets. 
 
Example 
 
 <font face=”Times New Roman”  size=”5”  color=”#FF0000”>Test</font> 
 
 will generate… 
 
 Test 
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<b> 
Defines bold text. 
 
<i> 
Defines italic text. 
 
<u> 
Defines underlined text. 
 
<sub> 
Defines subscript text. 
 
<sup> 
Defines superscript text. 
 
 
 
 
Tables 
 
Tables are defined with the <table> tag. A table is divided into rows (with the <tr> tag), and each row is 
divided into cells (with the <td> tag). The letters td stands for "table data," which is the content of a data 
cell. A data cell can contain text, images, lists, paragraphs, forms, horizontal rules, tables, etc. 
 
Example 
 
 <table border="1"> 

<tr> 
<td>row 1, cell 1</td> 
<td>row 1, cell 2</td> 
</tr> 
<tr> 
<td>row 2, cell 1</td> 
<td>row 2, cell 2</td> 
</tr> 
</table> 
 
will generate… 
 
row 1, cell 1 row 1, cell 2 
row 2, cell 1 row 2, cell 2 
 
In this example, the attribute border=”1” defines the thickness of the table frame. border=”0” 
would make the table frame invisible, leaving only the text. 

 
 
Miscellaneous Tags 
 
<a> 
This tag defines a link that is attached to a piece of text. 
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Example 
 
 <a href=http://www.ias.edu/>The IAS website.</a> 
 
 will generate… 
 
 The IAS website. 
 
<hr> 
Defines a horizontal rule. 
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